POJ1142——Smith Numbers

Smith Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12388 Accepted: 4244

Description

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:
4937775= 3*5*5*65837

The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers.
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition.
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775

Source

Mid-Central European Regional Contest 2000

简单的质因数分解题

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int a[10010];
int b[10010];
int tot;

bool is_prime(int n)
{
	int temp = (int)sqrt((double)n + 1);
	for(int i = 2; i <= temp; i ++)
		if( n % i == 0)
			return false;
	return true;
}

int digit_sum(int n)
{
	int sum = 0;
	while(n)
	{
		sum += n % 10;
		n /= 10;
	}
	return sum;
}

void prime_factor(int n)
{
	int temp = (int)sqrt((double)n + 1);
	int cur = n;
	for(int i = 2;i <= temp; i ++)
	{
		if(cur % i == 0)
		{
			a[++ tot] = i;
			b[tot] = 0;
			while(cur % i == 0)
			{
				b[tot] ++;
				cur /= i;
			} 
		}
	}
	if(cur != 1)
	{
		a[++ tot] = cur;
		b[tot] = 1;
	}
}

int main()
{
	int n;
	while(~scanf("%d", &n), n)
	{
		int cur = n;
		int sum1, sum2;
		while(1)
		{
			cur ++;
			if( is_prime(cur) )
				continue;
			sum1 = digit_sum(cur);
			sum2 = 0;
			tot = 0;
			prime_factor(cur);
			for(int i = 1; i <= tot; i ++)
			{
			//	printf("%d %d\n", a[i], b[i]);
				sum2 += digit_sum(a[i]) * (b[i]);
			}	
			if(sum1 == sum2)
				break;
		}
		printf("%d\n", cur);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值