HDU 1016 Prime Ring Problem(排列的种数----DFS)

Prime Ring Problem
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


  Prime Ring Problem 

A ring is composed of n (even number) circles as shown in diagram. Put natural numbers $1, 2, \dots, n$ into each circle separately, and the sum of numbers in two adjacent circles should be a prime.


Note: the number of first circle should always be 1.

Input 

n (0 < n <= 16)

Output 

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.


You are to write a program that completes above process.

Sample Input 

6
8

Sample Output 

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2



Miguel A. Revilla
1999-01-11

题目大意:

输出换的排列方式,要求相邻的两数之和为质数。

解题思路:

DFS.


#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;

int n,visited[25];
vector <int> path,v[25];

bool isPrime(int x){
    for(int i=2;i*i<=x;i++){//不用sqrt,易损精度.
        if(x%i==0)
            return false;
    }
    return true;
}

void dfs(int s){
    visited[s]=true;
    path.push_back(s);
    if(path.size()<n){
        for(int i=0;i<v[s].size();i++){
            int d=v[s][i];
            if(visited[d]==false)
                dfs(d);
        }
    }
    else{
        if(isPrime(path.back()+1)){
            for(int i=0;i<n;i++){
                if(i>0) printf(" ");
                printf("%d",path[i]);
            }
            printf("\n");
        }
    }
    path.pop_back();
    visited[s]=false;
}

void solve(){
    for(int i=1;i<=n;i++){
        visited[i]=false;//初始化.
        v[i].clear();
    }
    for(int i=1;i<=n;i++){
        for(int j=i+1;j<=n;j++){
            if(isPrime(i+j)){
                v[i].push_back(j);
                v[j].push_back(i);
            }
        }
    }
    dfs(1);
}

int main(){
    int casen=0;
    while(scanf("%d",&n)!=EOF){
        if(casen>0) printf("\n");
        printf("Case %d:\n",++casen);
        solve();
    }
    return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 、5资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值