UVA 439 Knight Moves(BFS)


 Knight Moves

From:UVA, 439

Time Limit: 3000 MS

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set ofn squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


题目大意:

给你起点和终点,按照象棋里面的象走日的走法,要走几步。

解题思路:

这代题目调试了几个小时,原来是错在节点坐标没初始化,所以做题还是要小心啊。


代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<queue>

using namespace std;

struct node{
    int i,j,step;
    node(int i0=0,int j0=0,int step0=0){i=i0,j=j0,step=step0;}
}mymap[10][10];

int dirX[8]={ 1,-1,-1, 1,2, 2,-2,-2};//
int dirY[8]={-2,-2, 2, 2,-1,1,-1,1},i1,j1,i2,j2;
char c1,c2;

bool judge(int di,int dj){
    if(di>=0&&di<8&&dj>=0&&dj<8) return true;
    return false;
}

bool read(){
    if(cin>>c1>>j1>>c2>>j2){
        i1=c1-'a',i2=c2-'a',j1--,j2--;
        return true;
    }
    return false;
}

void initial(){
    for(int i=0;i<8;i++){
        for(int j=0;j<8;j++){
            mymap[i][j].step=-1;
            mymap[i][j].i=i;//哎。
            mymap[i][j].j=j;//之前死在这。
        }
    }
}

void bfs(){
    queue <node> path;
    bool ans =false;
    mymap[i1][j1].step=0;
    path.push(mymap[i1][j1]);
    while(!path.empty()&&!ans){
        node s=path.front();
        path.pop();
        for(int k=0;k<8;k++){
            int di=s.i+dirY[k],dj=s.j+dirX[k];
            if(judge(di,dj)&&mymap[di][dj].step==-1){
                mymap[di][dj].step=s.step+1;
                path.push(mymap[di][dj]);
            }
            if(di==i2&&dj==j2) {ans=true;break;}
        }
    }
}

void outResult(){
    printf("To get from %c%d to %c%d takes %d knight moves.\n",c1,j1+1,c2,j2+1,mymap[i2][j2].step);
}

int main(){
    while(read()){
        initial();
        bfs();
        outResult();
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值