UVA 580



Critical Mass

      Time Limit: 3000ms                                      Memory Limit: 131072KB

[PDF Link]


  Critical Mass 

During the early stages of the Manhattan Project, the dangers of the new radioctive materials were not widely known. Vast new factory cities were built to manufacture uranium and plu- tonium in bulk. Compounds and solutions of these substances were accumulating in metal barrels, glass bottles and cardboard box piles on the cement floors of store rooms. Workers did not know that the substances they were handling could result in sickness, or worse, an explosion. The officials who new the danger assumed that they could ensure safety by never assembling any amount close to the critical mass estimated by the physicists. But mistakes were made. The workers, ignorant of the the dangers, often did not track these materials care- fully, and in some cases, too much material was stored together - an accident was waiting to happen.


Fortunately, the dangers were taken seriously by a few knowledgeable physicists. They drew up guidelines for how to store the materials to eliminate the danger of critical mass accumulations. The system for handling uranium was simple. Each uranium cube was marked ``U''. It was to be stacked with lead cubes (marked ``L'') interspersed. No more than two uranium cubes could be next to each other on a stack. With this simple system, a potential for the uranium reaching critical mass (three stacked next to each other) was avoided. The second constraint is that no more than thirty cubes can be stacked on top of each other, since the height of the storage room can only accommodate that many.


One of the physicists was still not completely satisfied with this solution. He felt that a worker, not paying attention or not trained with the new system, could easily cause a chain reaction. He posed the question: consider a worker stacking the radioactive cubes and non radioactive cubes at random on top of each other to a height of n cubes; how many possible combinations are there for a disaster to happen?

For example, say the stack is of size 3. There is one way for the stack to reach critical mass - if all three cubes are radioactive.


1: UUU


However, if the size of the stack is 4, then there are three ways:


1: UUUL

2: LUUU

3: UUUU

Input 

The input is a list of integers on separate lines. Each integer corresponds to the size of the stack and is always greater than 0. The input is terminated with a integer value of  0 .

Output 

For each stack, compute the total number of dangerous combinations where each cube position in the linear stack can either be `` L '' for lead, or `` U '' for uranium. Output your answer as a single integer on a line by itself.

Sample Input 

4
5
0

Sample Output 

3
8


题目大意:

箱子里可以放U或者L,如果连续三个或以上的U放在一起就会有危险,问你有多少种危险的放法。


解题思路:

递归:f(n)表示第n个箱子满足条件,如果第n-1个箱子已经满足条件了,则第n个可以放U或者是L,则f(n)=2*f(n-1).如果第n-1个箱子不满足条件,则满足条件的情况下,最后四个箱子的排列一定会是LUUU的形式,则f(n)=2^(n-4)-f(n-4).

故f(n)=2*f(n-1)+2^(n--4)-f(n-4)。

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;

const int maxn=100;
int f[maxn],n;

void init(){
    f[3]=1;
    f[4]=3;
    for(int i=5;i<maxn;i++){
        f[i]=2*f[i-1]+(1 << (i-4))-f[i-4];
    }
}

int main(){
    init();
    while(~scanf("%d",&n)&&n){
        cout<<f[n]<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值