HDU 2899 Strange fuction 二分 + 精度控制

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2662    Accepted Submission(s): 1984


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
 


相当于y是个常数求 F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)这个函数的最小值,令F' = 0,得出x,y的方程,用二分法解方程得x0(易证得x0>=0 && x0<=100),则F'(x0) = 0,由F'' 在[0-100]上恒大于0,所以F'在[0-100]上单增,所以F'(x)<0(x<x0),F'(x)>0(x>x0),所以F(x)在x=x0处取得最小值,所以本题主要就是二分求解方程的x0,然后直接带入x0,y计算即可。

#include <cstdio>
#include <cmath>
#include <cstdlib>

const double eps = 1e-6;

double cal(double x){
	return 42*pow(x,6.0)+48*pow(x,5.0)+21*pow(x,2.0)+10*x;
}

double gao(double x,double y){
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-x*y;
}

int main(){
	int t;
	double low,high,y,x,res;

	scanf("%d",&t);
	while(t--){
		scanf("%lf",&y);
		low = 0.0;
		high = 100.0;
		while(high-low>eps){
			x = (low+high)/2;
			res = cal(x);
			if(res<y){
				low = x + 1e-8;
			}else{
				high = x - 1e-8;
			}
		}
		printf("%0.4lf\n",gao(x,y));
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值