HDU 2899 (二分)

Problem Description

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

 

Input 

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

 

Output 

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

 

Sample Input 

2

100

200

 

Sample Output 

-74.4291

-178.8534

 

思路:

题意为求最小值,对于函数求最值,首先就是求导。

我们对f(x)求导之后得到:f'(x)=42*x^6+48*x^5+21*x*x+10x-y

当f'(x)=0时取得最值,然后由于定义域x属于[0,100]那么可以推断,f'(x)先为负,再为正。f(x)先减后增。当f'(x)=0时,

f(x)有最小值。

我们可以利用二分算法去计算f'(x)=0时x为多少(注意f'(x)是单调递增的)

计算出x之后再代入原函数解出最小值即可。

注意:此题要求结果保留4位小数。

 

代码:

#include<iostream>
#include<cstdio>
#include <algorithm>
#include<cstring>
#include<cmath>
#define eps 1e-15
using namespace std;
double F(double x,double y)
{
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f(double x)
{
	return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main()
{
	int t;
	double y,l,h,mid;
	cin>>t;
	while(t--)
	{
		cin>>y;
		l=0.0;h=100.0;
		while(h-l>1e-7)
		{
			mid=(l+h)/2;
			if(f(mid)<y) l=mid;
			else h=mid;
		}
        printf("%0.4lf\n",F(mid,(double)y));


	}

	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值