hdu1227 Fast Food--DP

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1227


一:原题内容

Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
 
Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.
 
Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.

Output a blank line after each test case.
 
Sample Input
  
  
6 3 5 6 12 19 20 27 0 0
 
Sample Output
  
  
Chain 1 Total distance sum = 8

二:分析理解

在n个商店中建m个仓库,使各个商店到仓库的路程之和最小,商店到哪个仓库是有选择的,
总之路程之和要最小!

仓库要建在商店的位置,也就是说,它一定在某个商店的坐标处;
首先:
我们可以将一下n个商店的位置存入dis[]数组(这里注意,这里说的是位置,我们可以想象,highway当做一个数轴来看,那么dis[i]就代表第i个商店在数轴上的坐标,就是位置,它不代表距离);

然后:
我们要算出从第i个商店到第j个商店之间建一个仓库之后又增加的距离case[i][j],这里要明白,从第i个商店到第j个商店建一个仓库,这个仓库所建的位置一定是dis[(i+j)/2],即建在它的中位数处,所以,这个增加值就是case[i][j]=abs(dis[k]-dis[(i+j)/2])(i<=k<=j);

dp[i][j]代表前j个商店建i个仓库的最小距离。还是直接看代码吧,没那么难理解。

如果不懂可以参考: http://www.cnblogs.com/jackge/archive/2013/03/27/2984463.html http://www.2cto.com/kf/201403/283376.html


(相当于把线段上的点分为几段)


三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>  
#include<cmath>

using namespace std;

int cost[205][205];
int dp[35][205];
int dis[205];

int main()
{
	int cas = 1;

	int n, k;

	while (scanf("%d%d", &n, &k) && (n||k))
	{
		for (int i = 1; i <= n; i++)
			scanf("%d", &dis[i]);

		memset(cost, 0, sizeof(cost));//必须要初始化

		for (int i = 1; i <= n; i++)
		{
			for (int j = i; j <= n; j++)
			{
				int mid = (i + j) / 2;
				for (int p = i; p <= j; p++)
					cost[i][j] += abs(dis[p] - dis[mid]);
			}
		}

		for (int i = 1; i <= n; i++)//初始化
			dp[1][i] = cost[1][i];

		for (int i = 2; i <= k; i++)
		{
			for (int j = i; j <= n; j++)
			{
				dp[i][j] = 99999999;
				for (int m = i - 1; m <= j - 1; m++)
					dp[i][j] = min(dp[i][j], dp[i - 1][m] + cost[m + 1][j]);
			}
		}

		printf("Chain %d\n", cas++);
		printf("Total distance sum = %d\n\n", dp[k][n]);//输出两个空格
	}

	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值