hdu 1016 Prime Ring Problem DFS解法 纪念我在杭电的第一百题

154 篇文章 1 订阅
33 篇文章 0 订阅

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29577    Accepted Submission(s): 13188


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 我的第一百题和进杭电前一万名,,全贡献给了水题o(╯□╰)o
竟然格式错误两次!!
入门DFS。
下面代码:

#include <stdio.h>
#include <string.h>
#define MAX 25

bool visited[MAX] ;
int n , ans[MAX] ;
bool prime[2*MAX];

void DFS(int num)
{
	if(num == n)
	{
		if(!prime[ans[num-1]+1])
			return  ;
		for(int i = 0 ; i < n ; ++i)
		{
			printf("%d",ans[i]);
			if(i != n-1)
			{
				printf(" ");
			}
		}
		printf("\n") ;
		return ;
	}
	else
	{
		for(int i =  1 ; i <= n ; ++i)
		{
			if(!visited[i] && prime[i+ans[num-1]])
			{
				visited[i] = true ;
				ans[num] = i;
				DFS(num+1);
				visited[i] = false ;
			}
		}
	}
}

int main()
{
	for(int i = 2 ; i < 51 ; ++i)	prime[i] = true ;
	prime[0]=prime[1]=false;
	prime[2] = true ;
	for(int i = 2 ; i < 51; ++i)
	{
		for(int j = 2 ; j*i < 51 ; ++j)
		{
			prime[i*j] = false ;
		}
	}
	
	ans[0] = 1 ;
	int c=1;
	while(~scanf("%d",&n))
	{
		memset(visited,0,sizeof(visited));
		visited[1] = true ;
		printf("Case %d:\n",c++);
		DFS(1);
		printf("\n");
	}
	return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值