Prime Ring Problem(经典回溯法)

47 篇文章 0 订阅

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source
Asia 1996, Shanghai (Mainland China)

题意:输入n(0<n<20),使1到n个数组成一个素数环(即相邻的两个数之和为素数),依次输出所有的组成方法
分析:DFS(此题也可称回溯)
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=22;
int n,vis[N],a[N];
int flag[55],isp[55];///isp[i]是记录i是否为素数的数组
void is_prime()///素数打表
{
    int k=0;
    memset(isp,0,sizeof(isp));
    memset(flag,0,sizeof(0));
    for(int i=2; i<=7; i++)
        if(!flag[i])
            for(int j=i*i; j<=50; j+=i)
                flag[j]=1;
    for(int i=2; i<=50; i++)
        if(!flag[i])
            isp[i]=1;
}
void init()///初始化
{
    for(int i=0; i<N; i++)
        a[i]=i+1;
}
void dfs(int x)
{
    if(x==n&&isp[a[0]+a[n-1]])///每个数都用到且首位元素和为素数
    {
        printf("%d",a[0]);
        for(int i=1; i<n; i++)
            printf(" %d",a[i]);
        printf("\n");
    }
    else
        for(int i=2; i<=n; i++) ///尝试放每个数
        {
            if(!vis[i]&&isp[i+a[x-1]])///若i没用过且与前一个数的和为素数
            {
                a[x]=i;///储存这个数
                vis[i]=1;
                dfs(x+1);
                vis[i]=0;
            }
        }
}
int main()
{
    is_prime();
    int k=0;
    while(~scanf("%d",&n))
    {
        init();
        printf("Case %d:\n",++k);
        memset(vis,0,sizeof(vis));
        dfs(1);
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
Eprime是一种心理学研究软件,广泛应用于心理学领域的实验研究中。Eprime经典程序案例是指在使用Eprime软件进行实验设计和实施时最常用的一些范例。 一个经典的Eprime程序案例是视觉搜索任务。研究者可以使用Eprime设计并实施一个视觉搜索实验,以研究不同条件下被试对视觉刺激的注意力分配和反应时间的影响。在这个任务中,被试需要根据特定的规则在一系列视觉刺激中找到目标刺激。例如,被试可能被要求找到一个特定形状或颜色的目标刺激。Eprime可以用来生成并显示刺激,记录被试的反应时间和准确性,并进行数据分析。 另一个经典的Eprime程序案例是工作记忆任务。工作记忆是指短期记忆和认知控制过程共同参与的一种记忆系统。研究者可以使用Eprime设计并实施一个工作记忆实验,以研究不同条件下工作记忆负荷对认知表现的影响。在这个任务中,被试需要记住一系列的刺激,并在随后的测试中判断是否出现了重复的刺激。Eprime可以用来呈现和记录刺激,以及计算被试的反应时间和准确性。 通过Eprime经典程序案例,研究者可以利用该软件进行心理学研究实验的设计、执行和数据分析。Eprime的特点包括易用性、灵活性和高度控制性,使得研究者能够轻松地创建复杂的实验范例,并获得可靠和准确的实验数据。这些经典的Eprime程序案例为心理学研究提供了重要的工具和方法,促进了对认知和行为的深入理解。
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值