PAT甲级-1140. Look-and-say Sequence (20)(模拟)

1140. Look-and-say Sequence (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:

1123123111

题目意思:

对于样例 :D, D1, D111, D113, D11231, D112213111,

D是首项“D”,其中D是一个给定的0~9的整数;

D1表明D中连续“D”有“1”个;

D111表明D1中连续“D”有“1”个,连续“1”有“1”个;

D113表明D111中连续“D”有“1”个,连续“1”有“3”个;

D11231表明D113连续“D”有“1”个,连续“1”有“2”个,连续“3”有“1”个;

以此类推……


给定D,求第N项的表示方法。


解题思路:

用字符数组存储,依次遍历前一个字符,计数连续出现的字符,存入当前字符。


#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 1010
string a[MAXN];

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int d,n;
    cin>>d>>n;
    a[0]=char(d+'0');
    a[1]=a[0]+"1";
    for(int i=2; i<n; ++i)
    {
        string s=a[i-1];
        int cnt=1;
        int len=s.length();
        for(int j=1; j<len; ++j)//遍历前一个串
        {

            if(s[j]==s[j-1]) ++cnt;
            else
            {
                a[i]+=s[j-1];//元素
                a[i]+=char(cnt+'0');//个数
                cnt=1;
            }
        }
        a[i]+=s[len-1];//加上最后一次的计数
        a[i]+=char(cnt+'0');
    }
    //for(int i=1; i<n; ++i)
    cout<<a[n-1]<<endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值