1140 Look-and-say Sequence (20 分)
Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, ...
where D
is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D
in the 1st number, and hence it is D1
; the 2nd number consists of one D
(corresponding to D1
) and one 1 (corresponding to 11), therefore the 3rd number is D111
; or since the 4th number is D113
, it consists of one D
, two 1's, and one 3, so the next number must be D11231
. This definition works for D
= 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D
.
Input Specification:
Each input file contains one test case, which gives D
(in [0, 9]) and a positive integer N (≤ 40), separated by a space.
Output Specification:
Print in a line the Nth number in a look-and-say sequence of D
.
Sample Input:
1 8
Sample Output:
1123123111
题意 : 根据给定的首位数字和进行的次数,写出最后的结果。具体规则如下,第n次的结果要根据第n-1次的结果来写,从前往后每两个字符的位置上,第一个代表具体意义上的字符,第二个代表字符出现的次数。
解题思想:每一次循环都对初始输入的字符串进行变化,记录连续字符出现的次数,将字符及其字数保存到字符串中,最后进行输出即可。
#include <iostream>
using namespace std;
int main()
{
int n;
string s;
cin>>s>>n;
int i;
for(i=1; i<n; i++)
{
char c=s[0];
string x;
int sum=0;
for(int j=0; j<s.size(); j++)
{
if(s[j]==c)
{
sum++;
}
else
{
x.append(1,c);
x.append(1,sum+'0');
sum=1;
c=s[j];
}
}
x.append(1,c);
x.append(1,sum+'0');
s=x;
}
cout<<s<<endl;
return 0;
}