PAT甲级 1140. Look-and-say Sequence (20)

1140. Look-and-say Sequence (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:
1123123111

题意很简单,输入两个数,第一个数是D的值,从0~9,第二个数是让你输出序列的第n个值。他的规则是是下一个数描述当前的数。就是几个0,几个1,几个2等等.....

当时比赛时候,因为不能Debug,也一直不知道自己错在哪,回到宿舍补题时候,重新写了一遍,17分,不知道为什么,可能宿舍电脑跟我时间长了,不好意思难为我吧,直接上代码

#include<bits/stdc++.h> 
#include<string.h>
#define inf 0x3f3f3f3f
using namespace std;
char s[1000000];
char s1[1000000];
int main()
{
	memset(s,'\0',sizeof(s));
	memset(s1,'\0',sizeof(s1));
	char d;
	int n;
	scanf("%c%d",&d,&n);
	s[0]=d;
	long long int i,m;
	while(n>1)
	{
		char k='0';
		m=0;
		for(i=0;i<strlen(s);i++)
		{
			while(s[i]==s[i+1])
			{
				k++;
				i++;
			}
			k++;
			s1[m++]=s[i];
			s1[m++]=k;
			k='0';
		}
		for(i=0;i<strlen(s1);i++)
		{
			s[i]=s1[i];
		}
		memset(s1,'\0',sizeof(s1));
		n--;
	}
	for(i=0;i<strlen(s);i++)
	{
		printf("%c",s[i]);
	}
	printf("\n");
	return 0;

}


最后三分tle了,学长跟我说后面的数据可以记录前面的数据,就是说有一部分是相同的,我是没有找到,也可能是他的臆测吧,希望大佬可以给一点建议,最后三分处理才能通过

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值