hdu 4722 GoodNumbers

数位DP水题

Good Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 955    Accepted Submission(s): 358


Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
  
  
2 1 10 1 20
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.


#include <map>
#include <set>
#include <list>
#include <ctime>
#include <cmath>
#include <queue>
#include <stack>
#include <bitset>
#include <vector>
#include <cstdio>
#include <cctype>
#include <string>
#include <cstring>
#include <sstream>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define PI 3.1415926535897932384626433832795
using namespace std;

long long T, l, r;
long long bit[20], dp[20][10];

long long work(long long n){
	int len = 0;
	memset(dp,0,sizeof(dp));
	while(n){
		bit[++len] = n % 10;
		n /= 10;
	}
	int tmp;
	for(int i = 1; i <= (len / 2); ++i){
		tmp = bit[len-i+1];
		bit[len-i+1] = bit[i];
		bit[i] = tmp;
	}

	int x = 0;
	for(int i = 1; i <= len; ++i){
		for(int j = 0; j <= 9; ++j)  //继承所有有效状态 
			for(int k = 0; k <= 9; ++k)
				dp[i][(j + k) % 10] += dp[i - 1][j];
		  
		for(int j = 0; j < bit[i]; ++j) // 开启所有有效状态,除过上界 
			dp[i][(x + j) % 10]++;
		x = (x + bit[i]) % 10;
	}
	dp[len][x]++;
	return dp[len][0];						
}

int main()
{
	cin >> T;
	for(int i = 1; i <= T; ++i){
		cin >> l >> r;
		cout << "Case #" << i << ": " << work(r) - work(l - 1) << endl;	
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值