HDU 4135 Co-prime(容斥原理+分解质因数)

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5239    Accepted Submission(s): 2093


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source
 

题意:
求出a-b中与n互质的数量。

POINT:
正难则反,求出a-b中不与n互质的数量。
先把n分解质因数,然后求出a-b中与这些质因数成倍数关系的数量。利用容斥原理。

但是我直接在b-(a-1)中找,无限WA.网上的题解是找出(1-b)的数量,在减去(1-a-1)的数量。不知道我这个为什么不行,也比对很多数据,都是一样的,除了A>B的情况,但是题目已经给出A<=B了呀。很奇怪。
void dfs(int ceng,int nowi,LL now)
{
    if(ceng==cnt+1) return;
    for(int i=nowi+1;i<=cnt;i++)
    {
        LL d=gcd(now,p[i]);
        LL sum=now/d*p[i];
       // if(sum>b) return;
        if(ceng&1)
        {
            ans+=b/sum-(a-1)/sum;
        }
        else
            ans-=b/sum-(a-1)/sum;
        dfs(ceng+1,i,sum);	
    }
}


AC代码:
没什么区别,就是找出(1-b)的数量,在减去(1-a-1)的数量。
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define  LL long long
LL a,b,m;
LL p[1000000];
int cnt;
LL ans;
LL anss;
LL gcd(LL A,LL B)
{
    if(A<B) swap(A, B);
    return B==0?A:gcd(B,A%B);
}
void prime()
{
    cnt=0;
    memset(p,0,sizeof p);
    for(LL i=2;i*i<=m;i++)
    {
        if(m%i==0)
        {
            p[++cnt]=i;
        }
        while(m%i==0) m/=i;
    }
    if(m>1)
        p[++cnt]=m;
}
void dfs(int ceng,int nowi,LL now)
{
    if(ceng==cnt+1) return;
    for(int i=nowi+1;i<=cnt;i++)
    {
        LL d=gcd(now,p[i]);
        LL sum=now/d*p[i];
       // if(sum>b) return;
        if(ceng&1)
        {
            ans+=b/sum;
        }
        else
            ans-=b/sum;
        dfs(ceng+1,i,sum);
    }
}
void ddfs(int ceng,int nowi,LL now)
{
    if(ceng==cnt+1) return;
    for(int i=nowi+1;i<=cnt;i++)
    {
        LL d=gcd(now,p[i]);
        LL sum=now/d*p[i];
        // if(sum>b) return;
        if(ceng&1)
        {
            anss+=(a-1)/sum;
        }
        else
            anss-=(a-1)/sum;
        ddfs(ceng+1,i,sum);
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    int k=0;
    while(T--)
    {
        ans=0;
        anss=0;
        scanf("%lld %lld %lld",&a,&b,&m);
        prime();
        dfs(1,0,1);
        ddfs(1,0,1);
        ans=(b-a+1)-(ans-anss);
        printf("Case #%d: %lld\n",++k,ans);
    }
}



Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值