HDU - 4135 - Co-prime - (容斥原理,分解质因数)

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N. 
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10  15) and (1 <=N <= 10  9).
Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
Sample Input
2
1 10 2
3 15 5
Sample Output
Case #1: 5
Case #2: 10


        
  
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}. 

题意是:给出区间[l,r]和一个整数n,让求在区间[l,r]中与n互素的数的个数

想到求[1,r]区间内与n互素的数的个数是容斥原理的经典应用,这里求区间[1,r]中与n互素的数的个数的方法是:通过反向思考先求解区间内与n不互素的数的个数,再用区间长度减之。将n分解质因子pi,那么区间[1,r]内整除pi的数有floor(r/pi)个,这里仅仅求∑floor(r/pi)作为不互素的数的个数还不对,因为区间内有的数可以被多个质因子整除,所以利用容斥原理,那么在知道怎么求区间[l,r]中与n互素的数的个数之后,用区间总长度r-l+1减去区间内不互素的数(solve(r)-solve(l-1))即是答案。

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;

vector<int> p;  //存放质因子
ll len;         //存放质因子个数
void init(ll n) //分解质因子
{
    for(ll i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            p.push_back(i);
            while(n%i==0)
                n=n/i;
        }
    }
    if(n>1)
        p.push_back(n);

    len=p.size();
}

ll solve(ll r)   //求在区间[l,r]中与n不互素的数的个数
{
    ll sum=0;
    for(ll msk=1;msk<(1ll<<len);msk++) //(1<<len)是一个长为len的二进制,通过msk从1到(1<<len)循环可以枚举这个二进制的每一种排列情况来表示每一种素因子的祝贺情况
    {
        ll mult=1,bits=0;
        for(ll i=0;i<len;i++) 
        {
            if(msk&(1ll<<i)) //判断i素因子是否在当前排列中,
            {
                ++bits;
                mult*=p[i];
            }
        }
        //比如有只有p1,p2在排列中,那么这一项为-r/(p1*p2),若只有p1那么+r/p1
        ll cur=r/mult;
        if(bits&1)
            sum+=cur;
        else
            sum-=cur;
    }
    return sum;
}

int main()
{
    int T,cas=0;
    ll a,b,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld%lld",&a,&b,&n);
        p.clear();
        init(n);
        printf("Case #%d: %lld\n",++cas,b-a+1-solve(b)+solve(a-1));
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值