HDU - 4355 Party All the Time 三分

Party All the Time

  HDU - 4355


In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S  3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x  i i<=x  i+1 i+1for all i(1<=i<N). The i-th line contains two real number : X  i,W  i, representing the location and the weight of the i-th spirit. ( |x  i|<=10  6, 0<w  i<15 )
Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
Sample Input
1
4
0.6 5
3.9 10
5.1 7
8.4 10
Sample Output
Case #1: 832

Source HDU - 4355
My Solution
题意:每个spirit有一个位置xi一个全中w[i],如果确定聚会地点为s,则i的花费是 fabs(s - x[i]) ^ 3 * w[i],求总花费。 三分 对位置xi进行三分,即把区间分为长度相等的三段,进行查找,这样的查找称为三分查找,三分查找通常用来迅速确定最值。 复杂度 略大于 O(nlogn)
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
typedef long long LL;
const int MAXN = 5e4 + 8;
const double EPS = 1e-4;

double x[MAXN], w[MAXN];
int n;

inline double getsum(double s)
{
    double res = 0, tmp;
    for(int i = 0; i < n; i++){
        tmp = fabs(s - x[i]);
        res += tmp*tmp*tmp*w[i];
    }
    return res;
}

int main()
{
    #ifdef LOCAL
    freopen("1.txt", "r", stdin);
    //freopen("1.out", "w", stdout);

    #endif // LOCAL
    //ios::sync_with_stdio(false); cin.tie(0);
    //HDU OJ 突然这句话失效了,迷之TLE很多次,改成scanf和printf就突然过了, ⊙﹏⊙‖∣
    int T, i, kase = 1;
    double l, r, ll, rr, ans1, ans2;
    //cin >> T;
    scanf("%d", &T);
    while(T--){
        l = 1e6 + 8, r = -(1e6 + 8);
        scanf("%d", &n);
        for(i = 0; i < n; i++){
            scanf("%lf%lf", &x[i], &w[i]);
            l = min(l, x[i]);
            r = max(r, x[i]);
        }
        while(l + EPS < r){
            ll = l + (r - l) / 3;
            rr = r - (r - l) / 3;
            ans1 = getsum(ll);
            ans2 = getsum(rr);
            if(ans1 > ans2){
                l = ll;
            }
            else r = rr;
        }
        ans1 = min(ans1, ans2);
        printf("Case #%d: %.0f\n",kase,ans1);
        kase++;
    }
    return 0;
}

Thannk you!                                                                                                                                              ------from  ProLights

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值