【HDU - 4355】Party All the Time (三分)

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |xi|<=10 6, 0<wi<15 )

Output

For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

Sample Input

 

Sample Output

 

思路:

根据题意,可以得出要求的函数是这样的:\sum_{i=1}^{n}(x-x_{i})^3*w_{i}。选择三分法来求解,最后结果四舍五入,这里我用了round()函数。

在网上也发现有大神用二分做出来了:https://blog.csdn.net/nameofcsdn/article/details/52042095

三分的ac代码:

//三分 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring> 
#include<queue>
#include<stack> 
#include<string.h>
#define eps 1e-8
using namespace std;
int n;
double x[50100],w[50100];
double cal(double q)
{
	double sum=0;
	for(int i=1;i<=n;i++)
	{
		sum+=abs((double)(q-x[i])*(q-x[i])*(q-x[i])*w[i]);
	}
	return sum;
}
int main()
{
	int t;
	scanf("%d",&t);
	int tt=1;
	while(t--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%lf%lf",&x[i],&w[i]);
		}
		double rmax=x[n],rmin=x[1],ans;
		while(rmax-rmin>=eps)
		{
			double mid=rmin+(rmax-rmin)/3;
			double midd=rmax-(rmax-rmin)/3;
			if(cal(mid)<cal(midd)) rmax=midd;
			else rmin=mid;
		}		
		ans=cal(rmin);
		printf("Case #%d: %d\n",tt++,(int)round(ans));
	}	 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值