hdu 4335 Party All the Time(三分求极值,3级)

Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2161    Accepted Submission(s): 732


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

Sample Input
 
  
1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

Sample Output
 
  
Case #1: 832
 

Author
Enterpaise@UESTC_Goldfinger
 

Source
 

Recommend
zhuyuanchen520


思路:三分球极值。为啥可以呢,不知道。


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int mm=5e4+9;
const double mx=1e-6;
const double oo=1e40;
class node
{
public:
  double x,y;
}f[mm];
int n;
double fabs(double x)
{
  if(x<0)return -x;
  return x;
}
double get(double mid)
{
  double ret=0.0,z;
  for(int i=0;i<n;++i)
  { z=fabs(mid-f[i].x);
    ret+=z*z*z*f[i].y;
  }
  return ret;
}
int main()
{
  int cas;
  while(~scanf("%d",&cas))
  {
    for(int ca=1;ca<=cas;++ca)
    {
      printf("Case #%d: ",ca);
      scanf("%d",&n);
      double l=oo,r=-oo;
      for(int i=0;i<n;++i)
      {
        scanf("%lf%lf",&f[i].x,&f[i].y);
        l=min(l,f[i].x);r=max(r,f[i].x);
      }
      double ll,rr;
      while(r-l>mx)
      {
        ll=(l+l+r)/3.0;
        rr=(l+r+r)/3.0;
        if(get(ll)>get(rr))
        {
          l=ll;
        }
        else
        {
          r=rr;
        }
      }
      //cout<<get(ll)<<endl;
      printf("%.0lf\n",get(l));
    }
  }
  return 0;
}




转载于:https://www.cnblogs.com/nealgavin/p/3205888.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值