poj2780Linearity【共线】

Language:
Linearity
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8242 Accepted: 1897

Description

Alice often examines star maps where stars are represented by points in a plane and there is a Cartesian coordinate for each star. Let the Linearity of a star map be the maximum number of stars in a straight line. 

For example, look at the star map shown on the figure above, the Linearity of this map is 3, because the star 1, star 2, and star 5 are within the same straight line, and there is no straight line that passes 4 stars. 

You are to write a program to find the Linearity of a star map. 

Input

Input will contain multiple test cases. Each describes a star map. 

For each test case, the first line of the input contains the number of stars N (2 <= N <= 1000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0 <= X, Y <= 1000). There can be only one star at one point of the plane. 

Output

Output the Linearity of the map in a single line.

Sample Input

5
0 0
2 0
0 2
1 1
2 2

Sample Output

3
题意:求一条直线与平面最多的点数相交;
本来还想用我写lightoj1292的代码来个1A却TLE了然后各种优化还是TLE无奈看了别人的思路固定一点求它到其他个点的斜率然后计算斜率相等的最大数目即可
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define inf 1e20
#define eps 1e-10
using namespace std;
struct point{
	double x,y;
}A[1010];
int seg(double n){
	if(fabs(n)<eps)return 0;
	else if(n<0)return -1;
	return 1;
}
int MAX(int a,int b){
	return a>b?a:b;
}
double K[1010];
bool cmp(double a,double b){
	return a<b;
}
double Slop(point a,point b){
	if(seg(a.x-b.x)==0)return inf;
	return (a.y-b.y)/(a.x-b.x);
}
int main()
{
	int n,i,j,k,ans,temp,m;
	while(scanf("%d",&n)!=EOF){
		for(i=0;i<n;++i){
			scanf("%lf%lf",&A[i].x,&A[i].y);
		}
		for(ans=0,m=0,i=0;i<n;++i,m=0){
			for(j=i+1;j<n;++j){
				K[m++]=Slop(A[i],A[j]);
			}
			sort(K,K+m,cmp);temp=1;
			for(int v=1;v<m;++v){
				if(seg(K[v]-K[v-1])==0)temp++;
				else{
					ans=MAX(ans,temp);
					temp=1;
				}
			}
			ans=MAX(ans,temp);
		}
		printf("%d\n",ans+1);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值