hdoj5972Fraction

Fraction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 349    Accepted Submission(s): 204


Problem Description
Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:


As a talent, can you figure out the answer correctly?
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n ( n8 ).

The second line contains n integers:  a1,a2,an(1ai10 ).
The third line contains n integers:  b1,b2,,bn(1bi10) .
 

Output
For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.
 

Sample Input
  
  
1 2 1 1 2 3
 

Sample Output
  
  
Case #1: 1 2
Hint
Here are the details for the first sample: 2/(1+3/1) = 1/2
 

Source
 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<set>
#include<list>
#include<vector>
using namespace std;
typedef long long LL;
typedef pair<int,int>pii;
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
int a[10],b[10];
int main()
{
    int t,Test=1;
    scanf("%d",&t);
    while(t--){
        int n;cin>>n;
        for(int i=1;i<=n;++i){
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;++i){
            scanf("%d",&b[i]);
        }
        int ansa=b[n],ansb=a[n];
        for(int i=n-1;i>=1;--i){
            int temp=ansb;
            ansb=a[i]*ansb+ansa;
            ansa=b[i]*temp;

        }
        int g=gcd(ansa,ansb);
        printf("Case #%d: %d %d\n",Test++,ansa/g,ansb/g);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值