hdoj N!

N!

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 27   Accepted Submission(s) : 8
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

1
2
6
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define maxn 40000
using namespace std;
int f[maxn];
int main()
{
    int s,c,i,j,n,k;
    while(scanf("%d",&n)!=EOF){
     memset(f,0,sizeof(f));
     f[0]=1;
     for(i=2;i<=n;i++){
      c=0;
      for(j=0;j<maxn;++j){
       s=f[j]*i+c;
       f[j]=s%10;
       c=s/10;}}
       for(j=maxn;j>=0;--j)if(f[j])break;
       for(i=j;i>=0;--i)
       printf("%d",f[i]);
       printf("\n");}
    return 0;
}
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值