#HDU 3371 Connect the Cities 【并查集、染色】

题目:

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15440    Accepted Submission(s): 4085


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
   
   
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
   
   
1
 

Author
dandelion
 

Source


思路:  题意为某地发洪水,某些地方还连在一起,有些地方已经淹掉了,需要将这些城市连在一起。

先将仍然连在一起的城市归入同一并查集,然后开始Kruskal算法即可。

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string.h>
#include<stdio.h>

using namespace std;

struct data{
	short be, ed;
	short len;
}dat[25005];;
short bcj[510];
int ans, node;

#ifdef DEBUG

#endif

short find(int x)
{
	if (bcj[x] == 0)
	{
		bcj[x] = x;
	}
	if (bcj[x] == x)
	{
		return x;
	}
	bcj[x] = find(bcj[x]);
	return bcj[x];
}

void merge(int x, int y)
{
	int a = find(x);
	int b = find(y);
	bcj[a] = b;
	return;
}

bool cmp(data a, data b)
{
	return a.len < b.len;
}

int main()
{
	int T;
	cin >> T;
	while (T--)
	{
		memset(bcj, 0, sizeof(bcj));
		ans = 0;
		int n, m, k;
		cin >> n >> m >> k;
		for (size_t i = 0; i < m; i++)
		{
			scanf("%d%d%d", &dat[i].be, &dat[i].ed, &dat[i].len);
			//cin >> dat[i].be >> dat[i].ed >> dat[i].len;
		}
		sort(dat, dat + m, cmp);
		for (size_t i = 0; i < k; i++)
		{
			int temp_using, temp_tar, temp_numb;
			scanf("%d", &temp_numb);
			//cin >> temp_numb;
			if (temp_numb != 0)
			{
				scanf("%d", &temp_tar);
				//cin >> temp_tar;
				temp_tar = find(temp_tar);
			}
			for (size_t s = 1; s < temp_numb; s++)
			{
				scanf("%d", &temp_using);
				//cin >> temp_using;
				if (bcj[temp_using] == 0)
				{
					bcj[temp_using] = temp_tar;
				}
				else
				{
					merge(temp_using, temp_tar);
				}
			}
		}
		for (size_t i = 0; i < m; i++)
		{
			if (find(dat[i].be) != find(dat[i].ed))
			{
				merge(dat[i].be, dat[i].ed);
				ans += dat[i].len;
			}
		}
		int findans = find(1);
		for (size_t i = 1; i <= n; i++)
		{
			if (find(i) != findans)
			{
				printf("-1\n");
				findans = -1;
				break;
			}
		}
		if (findans != -1)
		{
			cout << ans << "\n";
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值