#HDU 1312 Red and Black 【DFS入门】

题目:

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15201    Accepted Submission(s): 9409


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
   
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
   
   
45 59 6 13
 

Source
 

Recommend
Eddy



题意简单,给定一张图,包含起点位置,求从起点开始最多能走到的方块有多少个。

设置VIS数组用于存储是否踩过某块,在DFS过程中,若某点可以被踩且未被踩过,则ans加一。


全部处理完之后输出ans即可。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<queue>
#include<string.h>

using namespace std;

char data[30][30];
int ans, xx, yy, xbe, ybe;


void dfs(int x, int y)
{
	if (x>0 && x<30 && (data[x][y] == '@' || data[x][y] == '.'))
	{
		ans++;
		data[x][y] = 0;
		dfs(x - 1, y);
		dfs(x + 1, y);
		dfs(x, y - 1);
		dfs(x, y + 1);
	}
}

int main()
{
	while (cin >> xx >> yy)
	{
		ans = 0;
		memset(data, 0, sizeof(data));
		if (xx == 0 && yy == 0)
		{
			return 0;
		}
		for (size_t s = 1; s <= yy; s++)
		{
			for (size_t i = 1; i <= xx; i++)
			{
				cin >> data[s][i];
				if (data[s][i] == '@')
				{
					xbe = s;
					ybe = i;
				}
			}
		}
		dfs(xbe, ybe);
		cout << ans << "\n";
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值