#POJ 1195 Mobile phones 【二维树状数组】

题目:

Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 17385 Accepted: 8028

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source


思路: 需要进行一个二维数组的插入及查询操作,

二维数组的思路稍复杂些,一维树状数组查询a~b区间内的值  只需要将b的值减去a的值即可

但二维数组需要处理四个区间,

如 查询x1,y1~x2,y2间的值

需要计算   x2,y2+x1,y1-x1,y2+x2,y1四个区间

#define _CRT_SECURE_NO_WARNINGS

#include<iostream>
#include<stdio.h>
#include<map>
#include<algorithm>
#include<map>
#include<vector>
#include<string.h>
#include<string>

#define FOR(a) for(int i=0;i<a;i++)
#define CL(a) memset(a,0,sizeof(a))
int MAXN;
#define MAXNs 1250

using namespace std;

int data[MAXNs][MAXNs];

int lowbit(int x)
{
	return x&(-x);
}

void sumact(int x, int y, int num)
{
	while (x<MAXN)
	{
		int tempy = y;
		while (tempy < MAXN)
		{
			data[x][tempy] += num;
			tempy += lowbit(tempy);
		}
		x += lowbit(x);
	}
}

int sumque(int x, int y)
{
	int ans = 0;
	while (x > 0)
	{
		int tempy = y;
		while (tempy > 0)
		{
			ans += data[x][tempy];
			tempy -= lowbit(tempy);
		}
		x -= lowbit(x);
	}
	return ans;
}

int main()
{
	int x, y;
	int t;
	int op;
	while (cin >> op)
	{
		if (op == 0)
		{
			cin >> MAXN;
			MAXN += 2;
		}
		if (op == 1)
		{
			int x, y, num;
			scanf("%d%d%d", &x, &y, &num);
			x += 1, y += 1;
			sumact(x, y, num);
		}
		if (op == 2)
		{
			int x1, y1, x2, y2;
			scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
			x1 += 1;
			x2 += 1;
			y1 += 1;
			y2 += 1;
			long long ans = 0;
			ans += sumque(x2, y2);
			ans += sumque(x1 - 1, y1 - 1);
			ans -= sumque(x2, y1 - 1);
			ans -= sumque(x1 - 1, y2);
			cout << ans << "\n";
		}
		if (op == 3)
		{
			memset(data, 0, sizeof(data));
			continue;
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值