HDU 1671 && POJ 3630 Phone List (Trie树 好题)

129 篇文章 0 订阅
70 篇文章 0 订阅

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11721    Accepted Submission(s): 3982

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1671

题目大意:有n个号码,如果某个是另一个的前缀就是NO,否则是YES

题目分析:字典树的好题,判断时候有两点:
1.如果一个单词插入字典树时没有p -> next[idx] == NULL的情况,就是说其是某个已经存在的单词的前缀,则flag标记
2.如果查找时,还没找到头,就有p -> end == true,则说明存在其前缀,flag标记
还有一点要注意的是这题用指针做得delete否则mle

#include <cstdio>
#include <cstring>
char s[15];
bool flag;

struct node
{
    node *next[10];
    bool end;
    node()
    {
        memset(next, false, sizeof(next));
        end = false;
    }
};

void Insert(node *p, char *s)
{
    bool f = true;
    for(int i = 0; s[i] != '\0'; i++)
    {
        int idx = s[i] - '0';
        if(p -> next[idx] == NULL)
        {
            p -> next[idx] = new node();
            f = false;
        }
        p = p -> next[idx];
    }
    p -> end = true;
    if(f)
        flag = true;
}

void Search(node *p, char *s)
{   
    for(int i = 0; s[i] != '\0'; i++)
    {
        int idx = s[i] - '0';
        if(p -> end)
        {
            flag = true;
            return;
        }
        if(p -> next[idx] != NULL)
            p = p -> next[idx];
    }
}

void Delete(node *p)
{
    for(int i = 0; i < 10; i++)
        if(p -> next[i]) 
            Delete(p -> next[i]);
    delete p;
}

int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--)
    {
        flag = false;
        node *root = new node();
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
        {
            scanf("%s", s);
            Insert(root, s);
            if(!flag)
                Search(root, s);
        }
        printf("%s\n", flag ? "NO" : "YES");
        Delete(root);
    }
}


该题在poj上动态分配会T,要写静态的
#include <cstdio>
#include <cstring>
char s[15];
bool flag;
int cnt = 0;

struct node
{
    node *next[10];
    bool end;
}tree[100005];

inline void Init(node *p)
{
    memset(p -> next, NULL, sizeof(p -> next));
    p -> end = false;
}
void Insert(node *p, char *s)
{
    bool tmp = true;
    for(int i = 0; s[i]; i++)
    {
        int idx = s[i] - '0';
        if(p -> next[idx] == NULL)
        {
            tmp = false;
            cnt++;
            p -> next[idx] = tree + cnt;
            Init(p -> next[idx]);
        }
        p = p -> next[idx];
    }
    p -> end = true;
    if(tmp)
        flag = true;
}

void Query(node *p, char *s)
{
    for(int i = 0; s[i]; i++)
    {
        int idx = s[i] - '0';
        if(p -> end)
        {
            flag = true;
            return;
        }
        if(p -> next[idx] != NULL)
            p = p -> next[idx];
    }
}

int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--)
    {
        cnt = 0;
        flag = false;
        scanf("%d", &n);
        node *root = tree;
        Init(root);
        for(int i = 0; i < n; i++)
        {
            scanf("%s", s);
            Insert(root, s);
            if(!flag)
                Query(root, s);
        }
        printf("%s\n", flag ? "NO" : "YES");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值