HDU 1671 Phone List(字典树)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25986    Accepted Submission(s): 8682

 

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2

3

911

97625999

91125426

5

113

12340

123440

12345

98346

Sample Output

NO

YES

题目意思:输入若干组号码,判断任意一组号码是否是其它号码的前缀,如果存在一个号码是其它一个号码的前缀就输出"NO",如果不存在就输出"YES"。

题目做法:使用字典树将字符串存入,存入成功values++,在存入字符串时判断values值是否为0,不为0代表已经存在当前字符串的前缀,输出"NO",需要注意的是,当字符串长的在前,短的在后时,当短的字符串存入时,还要判断之后的孩子节点是否为NULL,不为空代表当前字符串为存入过的字符串的前缀,输出"NO"。

代码

#include<iostream>
#include<string>
#include<string.h>
#include<stdlib.h>
#include<stdio.h>
#include<sstream>
using namespace std;
struct Trie
{
    int values;
    Trie *child[10];
    Trie()
    {
        values=0;
        memset(child,NULL,sizeof(child));
    }
}*root;
bool f;
int ans=0;
void create(string s)                       //创建字典树并判断
{
    Trie *x=root;
    for(int i=0; i<s.length();i++)
    {
        int d=s[i]-'0';
        if(x->child[d]==NULL)
        {
            x->child[d]=new Trie;
        }
        x=x->child[d];
        if(x->values!=0)           //代表存在当前字符串的前缀
        {
            f=false;
            break;
        }
    }
    x->values++;
    for(int i=0;i<10;i++)         //判断之前存在包括它的字符串
    {
        if(x->child[i]!=NULL)
        {
            f=false;
            return;
        }
    }
}
void deleteTrie(Trie *x)            //清空内存
{
    if(x==NULL)
        return;
    for(int i=0; i<10; i++)
    {
        if(x->child[i]!=NULL)
        {
            deleteTrie(x->child[i]);
        }
    }
    delete x;
}
int main()
{
    int T,n,f1,k;
    string s;
    cin>>T;
    while(T--)
    {
        cin>>n;
        root=new Trie;
        f=true;
        k=n;
        while(n--)
        {
            cin>>s;
            create(s);
        }
        if(f==false)
        {
            cout<<"NO\n";
        }
        if(f==true)
            cout<<"YES\n";
        deleteTrie(root);
    }
}

  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值