HDU 3613 Best Reward (Manacher算法 前缀回文+后缀回文)

70 篇文章 0 订阅


Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 785    Accepted Submission(s): 338


Problem Description
After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value.

 

Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000.

 

Output
Output a single Integer: the maximum value General Li can get from the necklace.
 

Sample Input
  
  
2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac
 
Sample Output
  
  
1 6
 
Source
2010 ACM-ICPC Multi-University Training Contest(18)——Host by TJU


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3613

题目答疑:输入26个数字,分别表示26个字母的值,输入一个字符串,将这个字符串分成两半,若子串是回文串则其值为各字母之和否则为0,求所能得到的最大值

题目分析:先计算出字符串的前缀和,利用Manacher算法算出字符串的前缀回文序列和后缀回文序列并标记,然后每次加起来比较更新即可,实在感叹Manacher算法的强大!


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 500005;
char s[MAX << 1];
int p[MAX << 1], val[30], sum[MAX], len;
bool suf[MAX], pre[MAX];

void Manacher()
{
	int maxp = 0, maxl = 0;
	for(int i = len; i >= 0; i--)
	{
		s[i * 2 + 2] = s[i];
		s[i * 2 + 1] = '#';
	}
	s[0] = '*';
	for(int i = 2; i < 2 * len + 1; i++)
	{
		if(p[maxp] + maxp > i)
			p[i] = min(p[2 * maxp - i], p[maxp] + maxp - i);
		else 
			p[i] = 1;
		while(s[i - p[i]] == s[i + p[i]])
			p[i]++;
		if(p[maxp] + maxp < i + p[i])
			maxp = i;
		if(i - p[i] == 0)
			pre[p[i] - 1] = true;
		if(i + p[i] == 2 * len + 2)
			suf[p[i] - 1] = true;
	}
}

int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int ans = -0xfffffff;
		memset(suf, false, sizeof(suf));
		memset(pre, false, sizeof(pre));
		memset(sum, 0, sizeof(sum));
		for(int i = 0; i < 26; i++)
			scanf("%d", &val[i]);
		scanf("%s", s);
		len = strlen(s);
		for(int i = 1; i <= len; i++)
			sum[i] = sum[i - 1] + val[s[i - 1] - 'a'];
		Manacher();
		for(int i = 1; i < len; i++)
		{
			int tmp = 0;
			if(pre[i])
				tmp += sum[i];
			if(suf[len - i])
				tmp += sum[len] - sum[i];
			ans = tmp > ans ? tmp : ans;
		}
		printf("%d\n", ans);
	}
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值