hdu 2844 多重背包

 

 

   如题:http://acm.hdu.edu.cn/showproblem.php?pid=2844

 

  

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.


 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.


 

Output
For each test case output the answer on a single line.


 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0


 

Sample Output
  
  
8 4
 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

#define max(a,b)(a>b?a:b)

int w[103];
int num[103];
int f[100005];
int n,m;

void zeroonePack(int c,int w)
{
 int j;
 for(j=m;j>=c;j--)
  f[j]=max(f[j],f[j-c]+w);
}
void completePack(int c,int w)
{
 int j;
 for(j=c;j<=m;j++)
  f[j]=max(f[j],f[j-c]+w);
}
void multiplePack(int c,int w,int num)
{
 if(m<=c*num)
 {
  completePack(c,w);
 return;
 }
 int k=1;
 while(k<num)
 {
  zeroonePack(c*k,w*k);
  num-=k;
  k*=2;
 }
 zeroonePack(c*num,w*num);
}
int main()
{
 while(~scanf("%d%d",&n,&m)&&n&&m)
 {
  int i,j,k;
  memset(f,0,sizeof(f));
  for(i=1;i<=n;i++)
   scanf("%d",&w[i]);
  for(i=1;i<=n;i++)
   scanf("%d",&num[i]);
  for(i=1;i<=n;i++)
   multiplePack(w[i],w[i],num[i]);
  int sum=0;
  for(i=1;i<=m;i++)
   if(f[i]==i)
    sum++;
  printf("%d\n",sum);
 }
}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值