poj2139 floyd 最短路

 

 

如题:http://poj.org/problem?id=2139

Six Degrees of Cowvin Bacon
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3752 Accepted: 1747

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

Source

 

 

 

思路:题目说的很不清楚,开始认为要求输出的是一个顶点和其他顶点中的最短距离*100.wa了后看报告原来是输出最小的一个顶点到其他定点的距离的和/(顶点数-1)。

floyd书上在初始化的时候要求dis[i][i]=0.感觉没有必要,如果某一个点需要通过它自己更新,那也就是最开始边 权。我要是错了请告诉我。

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 305
#define inf 0x0fffffff
#define min(a,b)(a<b?a:b)

int G[MAXN][MAXN];

int main()
{
// freopen("C:\\1.txt","r",stdin);
 int N,M;
 cin>>N>>M;
 int i,j,k;
 for(i=1;i<=N;i++)
  for(j=1;j<=N;j++)
  {
  // if(i!=j)
    G[i][j]=inf;
  // else
  //  G[i][j]=0;
  }
 for(i=0;i<M;i++)
 {
  int n;
  cin>>n;
  int *a=new int[n];
  for(j=0;j<n;j++)
   cin>>a[j];
  for(j=0;j<n;j++)
   for(k=j+1;k<n;k++)
    G[a[j]][a[k]]=G[a[k]][a[j]]=1;
 }
 for(k=1;k<=N;k++)
  for(i=1;i<=N;i++)
   for(j=1;j<=N;j++)
    G[i][j]=min(G[i][j],G[i][k]+G[k][j]);
 int ans=inf;
 for(i=1;i<=N;i++)
 {
  int sum=0;
  for(j=1;j<=N;j++)
   if(i!=j)
    sum+=G[i][j];
  ans=min(ans,sum);
 }
 ans*=100;
 cout<<ans/(N-1)<<endl;
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值