lightoj 1282 Leading and Trailing(求n^k的前三位后三位)

142 篇文章 3 订阅

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669

题意:给出n和k,求出n^k的前三位和后三位

解题思路:

(建议在演草本上把以下步骤跟着推一遍,公式写出来就看得清楚就好理解多了)

求后三位:使用快速幂运算模板,要求后n位则对10^n取模,如本题求后三位只需将模板中mod的值传为10^3=1000

求前三位:

每一个数n都可以写作10^t(t大多是小数),则此时n^k可写作10^kt
n=10^t
n^k=10^kt
kt=x+y(x是整数部分,y是小数部分)

n^k=10^x * 10^y

因为x是整数,所示10^x是1,10,100,1000…表示的是n^k有多少位,
y是小数,10^y表示的是n^k的具体的数值。

所以我们要求n^k的前a位,即求10^(a-1+y)

(为什么是a-1? 答:指数函数10^x,当x>0时,10^x>1)

(4.27更新:10^y*10^(a-1)=10^(a-1+y)取出前a位数,如此时小数部分10^y=1.258我们要找前三位,即是1.258x10^(3-1)=1.258x100=125.8然后把125取出(怎么取出?答:强制转换为整形即可))

那么kt=k*log(10)n
y=fmod(kt,(int)kt)

所以结果就是(int)pow(10.0,(a-1)+fmod(kt,(int)kt) 就是上文的10^(a-1+y)

在本题中取前三位,则结果为
(int)pow(10.0,(3-1)+fmod(kt,(int)kt)=(int)pow(10.0,2+fmod(kt,(int)kt)

即是10^(3-1+y)=10^(2+y)

————–4.27—————–
附:
fmod函数:
函数原型:double fmod(double x,double y);
功能: 求整除x/y的余数
返回值: 返回余数的双精度数

(感谢老铁Qin7 双击666)

最后希望每个人都能看明白 :)

AC代码:

#include<stdio.h>
#include<math.h>

typedef long long ll;

ll mod_pow(ll x,ll n,ll mod)//快速幂对mod取模求后3位 
{
    ll res = 1;
    while(n>0)
    {
        if(n&1) res=res*x%mod;
        x=x*x%mod;
        n>>=1;
    }
    return res;
}

int FX(int n,int k)//求前三位 
{
    double tk=k*log10(1.0*n);
    int y=(int)pow(10.0,2+fmod(tk,(int)tk));
    return y;
}

int main()
{
    int t,q=1;
    scanf("%d",&t);
    while(t--)
    {
        ll n,k;
        scanf("%lld%lld",&n,&k);
        printf("Case %d: %d %03lld\n",q++,FX(n,k),mod_pow(n,k,1000)); //记住不足三位要补足三位,不然会wa
    }
    return 0;
}
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值