Lightoj 1282 (数学题)

Description
You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669

题意:让你求 n 的 k 次方的前三位与后三位;
题解:后三位直接就是快速幂,前三位要知道数学上的一点小知识,就是对于一个十进制数 n,log10(n)之后,整数部分是它的位数,小数部分是它每一位上的值,比如 101 = log10(1.01) * log10(100),其整数部分就是log10(100) == 2,小数部分就是 log10(1.01) ,所以要知道前三位,把小数部分求出来,10次方后乘100就好了。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define M 100010
#define LL long long
#define MOD (1000000000 + 7)
#define CRL(a, b) memset(a, b, sizeof(a))

LL quickpow(LL n, LL k, LL mod)
{
    LL res = 1;
    while(k)
    {
        if(k & 1)
        {
            res = res * n % mod;
        }
        n = (n % mod) * (n % mod) % mod;
        k >>= 1;
    }
    return res;
}
LL getf(LL n, LL k)
{
    double t1 = (double)k * (log10((double)n));
    t1 = t1 - (LL)(t1);
    t1 = pow(10, t1);
    LL ans = (LL)(t1 * 100);
    return ans;
}
int main()
{
    int t;
    scanf("%d", &t);
    LL n, k;
    for(int ca=1; ca<=t; ca++)
    {
        scanf("%lld%lld", &n, &k);
        LL ans1 = quickpow(n, k, 1000);//求后三
        LL ans2 = getf(n, k);//求前三
        printf("Case %d: %lld %03lld\n", ca, ans2, ans1);//注意一下,后三位可能有 012 这种情况
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值