数论 ( 求取大数n^k的前3位与后3位)

求取大数的后k位比较简单  即利用快速幂  取c = 10^k就可以 

模板:( 以  k =  3 为例)

long long int quick_mod( long long int a, long  long int b )
{
    long long int ans = 1;
    long long int c = 1000;
    a = a%c;
    while( b > 0 )
    {
        if( b%2 == 1 )
        {
            ans = ( ans*a)%c;
        }
        a = ( a*a)%c;
        b = b/2;
    }
    //printf("%lld\n", ans);
    return ans;
}

如果求取前几位 则需要用到下列公式 :

设 10^p = n^k  

两边取对数 即 p = k*log( 10)( n )

然后 x = ( long long int )p 存储p的整数部分

y = p-x 存储 p的小数部分

则 10^p = 10^( x+y) = n^k

10^y = n^k/10^x

因为x 为整数  所以10^y 就相当于你n^k小数位向前移动了  又y >= 0  所以10^y >= 1

所以

    ( long long int )( 10 ^ y *100)  double p = k*log10( double( n ) );
        long long int x = ( long long int )p;
        double y = p - x;
        long long int an  = ( int )(pow( 10, y )*100);即为n^k 的前三位

 

例题跟踪

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

 

坑 : 最后三位为023 时也应该输出023

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include <queue>
using namespace std;
int quick_mod( long long int a, long  long int b )
{
    long long int ans = 1;
    long long int c = 1000;
    a = a%c;
    while( b > 0 )
    {
        if( b%2 == 1 )
        {
            ans = ( ans*a)%c;
        }
        a = ( a*a)%c;
        b >>= 1;
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d", &t);
    long long int n , k;
    int cnt = 1;
    while( t-- )
    {
        scanf("%lld%lld", &n, &k);
       

       int ans =  quick_mod( n , k );
       

      double p = k*log10( double( n ) );
       

      long long int x = ( long long int )p;
       

     double y = p - x;
     

    int an  = ( int )(pow( 10, y )*100);
       

    printf("Case %d: %03d %03d\n" ,cnt++,  an, ans );
    }
}

希望可以对你有所帮助!!

 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值