hdu 1238 Substrings

10 篇文章 0 订阅

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5631    Accepted Submission(s): 2477


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
  
  
2 2
经典搜索题,显然要先按字符串长短排序,拿最短的那个字符串,枚举它的子串,看是否在其他字符串中都能找到,若找不到,则颠倒该子串再 看是否在其他字符串中都能找到。
这里用了C++中强大的string
AC代码:
#include <iostream>
#include <algorithm>
#include <string>

using namespace std;
int cmp(string a,string b)
{
    return a.size()<b.size();
}
int main()
{
    string s[105];
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=0; i<n; i++)
            cin>>s[i];
        sort(s,s+n,cmp);
        int len=s[0].length();
        int max=0;
        for(int j=1; j<=len; j++)
            for(int i=0; i+j<=len; i++)
            {
                string ss=s[0].substr(i,j);   //substr(i,j)表示从s[i]开始截取j长度的字符串
                int flag=1;
                for(int k=1; k<n; k++)
                    if(s[k].find(ss)==s[k].npos)   //找不到时返回s[k].npos
                    {
                        flag=0;
                        break;
                    }
                if(!flag)
                {
                    flag=1;
                    reverse(ss.begin(),ss.end());  //颠倒该子串
                    for(int q=1; q<n; q++)
                        if(s[q].find(ss)==s[q].npos)
                        {
                            flag=0;
                            break;
                        }
                }
                if(flag)
                {
                    if(j>max) max=j;
                }
            }
        cout<<max<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值