hdu 4475 Downward paths

10 篇文章 0 订阅

Downward paths

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 350    Accepted Submission(s): 106


Problem Description
================
  Hi! I am an ACMer from CSU. This contest made by me is to celebrate my girlfriend’s birthday although the problems in this contest do not relate to her in fact. :) Any way, happy birthday to you, honey!
  Thanks to LCY, I have this chance to share my ideas and works with you. Good luck and have fun!
================
  We have a graph with size = N like that in Figure 1. Then we are going to find a downward path from the top node to one bottom node.
  First, we select the top node as the beginning. Then at any node, we can go horizontally or downward along the blue edge and reach the next node. The finding will be end when we reach one of the bottom nodes. After that we can get a downward path from the top node to one bottom node. Note that we can not pass a blue edge that we have passed ago during each finding.
  Your task is to calculate there exists how many downward paths.
 

Input
  There is an integer T (1 <= T <= 1000) in the first line, which indicates there are T test cases in total.
  For each test case, there is only one integer N (1 <= N <= 10^18) indicates the size of the graph.
 

Output
  For each test case, you should output the correct answer of the above task in one line.
  Because the answer may be very large, you should just output the remainder of it divided by 1000003.
 

Sample Input
  
  
2 1 2
 

Sample Output
  
  
2 8
Hint
  For Sample 2, the yellow paths in Figure 2 show the 8 downward paths.
 

设size=i,答案是ai;

a1=2=1+1;

a2=8=2+2*2+2;

a3=48=8+8*2+8*2+8;

a4=384 =48+48*2+48*2+48*2+48;

......

很明显规律:an=an-1+2*(n-1)an-1+an-1=2*n*an-1;

即:an=2^n*n!

注意:1.an=2^n*n!,,,所以当n>1000003时,n!中有1000003这个因数,故ans=0,

AC代码:

#include <iostream>
#include <cstring>
#define mod 1000003
using namespace std;
long long a[mod+5];
int main()
{
    int t;
    long long n;
    a[0]=0;
    a[1]=2;
    for(int i=2;i<mod;i++)
    a[i]=a[i-1]*2*i%mod;
    cin>>t;

    while(t--)
    {
        cin>>n;
        if(n>=mod) cout<<"0"<<endl;
        else
        cout<<a[n]<<endl;
    }

return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值