UVA 489 - Hangman Judge做题心得

Hangman Judge

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.
代码如下:
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	char str1[100], str2[100];
	int k, j;
	while( cin>>k && k != -1)
	{
		cin>>str1>>str2;
		int nCount = 0;
		char *p;
		int i = 0, flag = 0;
		cout<<"Round "<<k<<endl;
		while( str2[i] != '\0')
		{
			p = strchr(str1,str2[i]);// 这里用来判断str2[i]是否在str1中存在
			if(p == NULL)
				nCount++;
			else
			{
				for( j = 0; j < strlen(str1); ++j)
				{
					if(str1[j] == str2[i])
						str1[j] = ' '; // 对在str1中与str[i]相同元素赋值处理
				}
			}
			for( j = 0; j < strlen(str1); ++j)
			{
				if(str1[j] != ' ')// 判断str1是否全部被赋值
					break;
			}
			if(j == strlen(str1)) // 注意判断位置
			{
				cout<<"You win."<<endl;
				flag = 1;
				break;
			}
			if(nCount == 7)
			{
				cout<<"You lose."<<endl;
				flag = 1;
				break;
			}
			++i;
		}
        if (!flag)
	        cout<<"You chickened out."<<endl;
	}
	return 0;
}
做题心得:
    其实这道题,题目中隐藏了细节,一开始思维不够严谨,没有考虑到“特殊”情况:当猜测的人猜对后还在猜,而且后面猜的错误次数>=7。比如:
1
cheese
cheesezxcvbnmas
这种情况应该属于猜对的情况。这就需要我们尽快判断猜测结果。而不能在while(str2[i] != '\0')循环结束后判断是否猜测成功!
    另外,为图方便,我没采用设置一个数组用来记录str2中的元素是否重复出现。而是借助strchr函数用来辅助判断。不过效率有所降低。
    最后,个人感觉这道题重在训练一个人逻辑思维的严密性。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值