文章标题 HDU 4788 : Hard Disk Drive (水)

Hard Disk Drive

Description

  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.

Input

  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.

Output

  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.

Sample Input

2
100[MB]
1[B]

Sample Output

Case #1: 4.63%
Case #2: 0.00%

题意:水题,就是求由于进制不同最终得到的结果比原来正常进制算少了百分之多少。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int main ()
{
    int t;
    scanf ("%d",&t);
    string a;
    int cnt=1;
    while (t--){
        cin>>a;
        int len=a.length();
        int place=0;
        for (int i=0;i<len;i++){
            if (a[i]=='['){//找到在那个区间
                place=i+1;
                break;
            }
        }
        double ans;
        if (a[place]=='B'){//如果是B直接输出0
            printf ("Case #%d: 0.00%%\n",cnt++);
        }
        else if (a[place]=='K'){//是K说明是(1000.0/1024)的一次方,后面一次类推
            ans=1-pow(1000.0/1024,1);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
        else if (a[place]=='M'){
            ans=1-pow(1000.0/1024,2);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
        else if (a[place]=='G'){
            ans=1-pow(1000.0/1024,3);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
        else if (a[place]=='T'){
            ans=1-pow(1000.0/1024,4);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
        else if (a[place]=='P'){
            ans=1-pow(1000.0/1024,5);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
        else if (a[place]=='E'){
            ans=1-pow(1000.0/1024,6);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
        else if (a[place]=='Z'){
            ans=1-pow(1000.0/1024,7);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
        else if (a[place]=='Y'){
            ans=1-pow(1000.0/1024,8);
            printf ("Case #%d: %.2f%%\n",cnt++,ans*100);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值