hdu4788 Hard Disk Drive (简单数学)

Problem Description

Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.

Input

The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.

Output

For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.

Sample Input

2
100[MB]
1[B]

Sample Output

Case #1: 4.63%
Case #2: 0.00%

Hint

在这里插入图片描述

思路:
因为求的都是百分比,很容易就可以推断出答案只与单位有关而与数字无关

b 的答案是 0.00% 

kb 的答案是 (1024*1024-1000*1000)/(1024*1024);
约一下就是 1-(1000*1000)/(1024*1024)
其中(1000*1000)/(1024*1024)1kb的实际量百分比,算出来为 0.9765625‬

mb 的答案是 (1024*1024*1024-1000*1000*1000)/(1024*1024*1024);
约一下就是 1-(1000*1000*1000)/(1024*1024*1024)

可以发现答案每次的答案就是 1-(0.9765625)^x ,x递增

预处理然后每次O(1)输出就行了

反思:
虽然过了,但是做的太慢了
code:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
string b,kb,mb,gb,tb,pb,eb,zb,yb;
//0.9765625‬
//x次幂的答案是1-(0.9765625)^x‬
void init(){
    b="0.00%";//0次幂
    kb="2.34%";//1次幂
    mb="4.63%";//2次幂
    gb="6.87%";//3次幂
    tb="9.05%";//4次幂
    pb="11.18%";//5次幂
    eb="13.26%";//6次幂
    zb="15.30%";//7次幂
    yb="17.28%";//8次幂
}
signed main(){
    init();
    int T;
    cin>>T;
    int cas=1;
    while(T--){
        string s;
        cin>>s;
        int i=0;
        while(s[i]!='[')i++;
        i++;
        printf("Case #%d: ",cas++);
        switch(s[i]){
            case 'B':cout<<b<<endl;
            break;
            case 'K':cout<<kb<<endl;
            break;
            case 'M':cout<<mb<<endl;
            break;
            case 'G':cout<<gb<<endl;
            break;
            case 'T':cout<<tb<<endl;
            break;
            case 'P':cout<<pb<<endl;
            break;
            case 'E':cout<<eb<<endl;
            break;
            case 'Z':cout<<zb<<endl;
            break;
            case 'Y':cout<<yb<<endl;
            break;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值