1017A除以B

本题要求计算A/B,其中A是不超过1000位的正整数,B是1位正整数。你需要输出商数Q和余数R,使得A = B * Q + R成立。

输入格式:

输入在1行中依次给出A和B,中间以1空格分隔。

输出格式:

在1行中依次输出Q和R,中间以1空格分隔。

输入样例:
123456789050987654321 7
输出样例:

17636684150141093474 3

#include<iostream>
#include<string>
#include<math.h>
using namespace std;
int main(){
	string str;
	int num;
	for(;cin>>str>>num;){
		if(str.length() == 1){
			cout<<(str[0] - '0')/num<<" "<<(str[0] - '0')%num<<endl;
		}else if(str.length() == 2){
			cout<<((str[0] - '0')*10 + str[1] - '0')/num<<" "
				<<((str[0] - '0')*10 + str[1] - '0')%num<<endl;
		}else{
			int remainder = ((str[0] - '0')*10 + str[1] - '0')%num;
			cout<<((str[0] - '0')*10 + str[1] - '0')/num;
			for(int i = 2;i < str.length();i++){
				int temp = str[i] - '0' + remainder*10;
				cout<<temp/num;
				remainder = temp % num;
			}
			cout<<" "<<remainder<<endl;
		}
	}
	return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值