The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:4 1 2 4 -1 4 7 6 -2 -3Sample Output:
43
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
for(int nc;cin>>nc;){
vector<int>coupons_positive;
vector<int>coupons_negative;
vector<int>products_positive;
vector<int>products_negative;
for(int i = 0;i < nc;i++){
int temp;
cin>>temp;
if(temp >= 0){
coupons_positive.push_back(temp);
}else{
coupons_negative.push_back(temp);
}
}
int np;
cin>>np;
for(int i = 0;i < np;i++){
int temp;
cin>>temp;
if(temp >= 0){
products_positive.push_back(temp);
}else{
products_negative.push_back(temp);
}
}
sort(coupons_positive.begin(),coupons_positive.end());
sort(coupons_negative.begin(),coupons_negative.end());
sort(products_positive.begin(),products_positive.end());
sort(products_negative.begin(),products_negative.end());
int sum = 0;
int i = coupons_positive.size()-1,j = products_positive.size()-1;
while(i >= 0 && j >= 0){
sum+= coupons_positive[i] * products_positive[j];
i--;
j--;
}
i = 0;
j = 0;
while(i < coupons_negative.size() && j < products_negative.size()){
sum += coupons_negative[i] * products_negative[j];
i++;
j++;
}
cout<<sum<<endl;
}
return 0;
}