POJ 3259 Wormholes(最短路,判断有没有负环回路)

F - Wormholes
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

这题就是判断存不存在负环回路。
前M条是双向边,后面的W是单向的负边。
 
为了防止出现不连通,
增加一个结点作为起点。
起点到所有点的长度为0

bellman_ford算法模板,可以处理图是否存在负环现象;

/*
 * POJ 3259
 * 判断图中是否存在负环回路。
 * 为了防止图不连通的情况,增加一个点作为起点,这个点和其余的点都相连,且距离为0。
 */

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <queue>
#include <map>
#include <set>
#define eps 1e-9

using namespace std;

/*
 * 单源最短路bellman_ford算法,复杂度O(VE)
 * 可以处理负边权图。
 * 可以判断是否存在负环回路。返回true,当且仅当图中不包含从源点可达的负权回路
 * vector<Edge>G;先G.clear()初始化,然后加入所有边
 * 假设图不存在负环,那么最短路最多经过(起点不算)n-1个结点,可以通过"n-1"轮松弛操作得到最短路;
 * 点的编号从1开始(从0开始简单修改就可以了)
 */
 
typedef long long ll;
typedef pair<int,int>P;
const int M = 600;
const int INF = 0x3f3f3f3f;
const int mod = 10000007;
int d[M];

struct Edge {
    int u,v,c;
    Edge(int _u = 0,int _v = 0,int _c = 0):u(_u),v(_v),c(_c) {}
};
vector<Edge>G;

bool bellman_ford(int start,int n) { //点的编号从1开始
    for(int i = 1; i <= n; i++) d[i] = INF;
    d[start] = 0;
    for(int i = 1; i < n; i++) { //最多松弛n-1次
        bool flag = true;
        for(int j = 0; j < G.size(); j++) {
            if(d[G[j].v] > d[G[j].u] + G[j].c) {
                flag = false;
                d[G[j].v] = d[G[j].u] + G[j].c;
            }
        }
        if(flag) return true; //没有负环回路
    }
    for(int i = 0; i < G.size(); i++) {
        if(d[G[i].v] > d[G[i].u] + G[i].c) return false; //有负环回路
    }
    return true; //没有负环回路
}

int main() {
    int T,n,m,w;
    cin>>T;
    while(T--) {
        G.clear();
        scanf("%d %d %d",&n,&m,&w);
        for(int i = 0; i < m; i++) {
            int u,v,c;
            scanf("%d %d %d",&u,&v,&c);
            G.push_back(Edge(u,v,c));
            G.push_back(Edge(v,u,c));
        }
        for(int i = 0; i < w; i++) {
            int u,v,c;
            scanf("%d %d %d",&u,&v,&c);
            G.push_back(Edge(u,v,-c));
        }
        for(int i = 1; i <= n; i++) {
            G.push_back(Edge(n + 1,i,0));
        }
        if(bellman_ford(n + 1,n + 1)) puts("NO");
        else puts("YES");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值