POJ 1330 Nearest Common Ancestors(LCA)

原题

A - Nearest Common Ancestors

 Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input


2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output


4
3

题意

构建一棵树,求两个结点的LCA(Least Common Ancestors),即最近公共祖先。

涉及知识及算法

LCA

可用一个足够大的数组用来存结点的父亲结点来构建树,如p[son]=par。为了快速找到LCA,可先计算两个结点的深度差,深度大的结点向上找父亲,直到深度相同。循环操作:判断两个结点是否相等,若相等则为LCA,否则两结点继续向上同时找父亲。

代码

#include <iostream>
#include <string.h>
using namespace std;

int p[10005];

int Findhight(int a)
{
    int hight=1;
    while(p[a])
    {
        hight++;
        a=p[a];
    }
    return hight;
}

int Findfather(int a,int b)
{
    int dis=Findhight(a)-Findhight(b);
    if(dis>0)
    {
        while(dis--)
        {
            a=p[a];
        }
    }
    else
    {
        while(dis++)
        {
            b=p[b];
        }
    }
    while(a!=b)
    {
        a=p[a];
        b=p[b];
    }
    return a;
}

int main()
{
    int kase,Count;
    int par,son;
    int son1,son2;
    cin>>kase;
    while(kase--)
    {
        memset(p,0,sizeof(p));
        cin>>Count;
        for(int i=0;i<Count-1;i++)
        {
            cin>>par>>son;
            p[son]=par;
        }
        cin>>son1>>son2;
        cout<<Findfather(son1,son2)<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值