CSU1977-Bit-reversal Permutation-模拟

CSU1977-Bit-reversal Permutation-模拟

Description

A fast Fourier transform (FFT) algorithm computes the discrete Fourier transform (DFT) of a sequence, or its inverse (IFFT). Fourier analysis converts a signal from its original domain (often time or space) to a representation in the frequency domain and vice versa. An FFT rapidly computes such transformations by factorizing the DFT matrix into a product of sparse (mostly zero) factors. As a result, it manages to reduce the complexity of computing the DFT from O(n*2), which arises if one simply applies the definition of DFT, to *O(n*log*n), where n is the data size.

——From Wikipedia

During this summer holiday, csuxushu feels so bored to learn FFT. Because FFT is a complicated algorithm, he need to apply a bit-reversal permutation to a sequence first before DFT which is a part of FFT.

In applied mathematics, a bit-reversal permutation is a permutation of a sequence of n items, where n = 2^k is a power of two. It is defined by indexing the elements of the sequence by the numbers from 0 to n − 1 and then reversing the binary representations of each of these numbers (padded so that each of these binary numbers has length exactly k). Each item is then mapped to the new position given by this reversed value.

Because all fellows in CSU(California State University ) can apply FFT, NTT or even FWT, it is a shame that he even doesn’t know how to take the first step. As one of the best computer programmer in CSU, can you help him?

You may think this problem is too hard to solve. In fact, it is a piece of cake to you. Remember to see the hint :-)

Input

The first line of the input gives the number of test cases T(T≤10); T test cases follow.Each test case contains a number sequence.
In each case, the first line is a number N(1≤N≤10^5), the number of elements in the following sequence.The second line is the sequence.Its length may not be exactly a power of two, so you can append some zeros to make it the minimal power of two larger than or equal to N.

Output

For each test case, output the sequence from input in bit-reversal order.

Sample Input

1
6
21 58 96 12 45 65

Sample Output

21 45 96 0 58 65 12 0

Hint

Bit-reverse Order
中文提示:可以看到,我们最终处理的系数从左至右的编号的二进制形式分别为000,100,010,110,001,101,011,111,若将其二进制反序,可得000,001,010,011,100,101,110,111,这些反序的二进制编码是从小到大排列的。也就是说,我们可以按照每个下标的二进制编码来确定处理系数的顺序。这种方法就称为位逆序置换(Bit-reversal permutation)


思路

Hint给的提示很明确了,其实就是首先把数组补成2^n个数,对应每个序号将其二进制表示视为一个字符串,对字符串进行排序后按新的顺序输出就好了

AC代码

/**************************************
 *Source            : CSU1977
 *Knowledge Point   : ADHOC
 *Author            : CSUzick
**************************************/
#include <cstdio>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <stack>
#include <vector>
#include <queue>
#include <cctype>
#include <cmath>
#include <algorithm>
#include <set>
#include <bitset>
#include <map>
#define LL long long
#define mk(a,b) make_pair(a,b)
#define ULL unsigned long long
#define mem(a,n) memset(a,n,sizeof(a))
#define fread freopen("in.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)
#define N 1010
#define INF 0x3f3f3f3f
#define eps 1e-9
using namespace std;
char per[(1<<17)+10][20];
int idx[(1<<17)+10];
int num[(1<<17)+10];
bool cmp(int i,int j){
    return strcmp(per[i],per[j])<0;
}
int main()
{
    int t,n,k,cnt;
    scanf("%d",&t);
    while(t--){
        k=1,cnt=1;
        scanf("%d",&n);
        while(k<n){
            k<<=1;
            ++cnt;
        }
        for(int i=0;i<n;++i){
            scanf("%d",num+i);
        }
        for(int i=n;i<k;++i){
            num[i]=0;
        }
        for(int i=0;i<k;++i){
            idx[i]=i;
            for(int j=cnt-2;j>=0;--j){
                if(i&(1<<(j))){
                    per[i][j]='1';
                }else{
                    per[i][j]='0';
                }
            }
            per[i][cnt-1]=0;
        }
        sort(idx,idx+k,cmp);
        for(int i=0;i<k;++i){
            printf("%d%c",num[idx[i]],(i==k-1?'\n':' '));
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值