算典03_例题_04_Uva-340

原题

Master-Mind Hints

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.
In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.
In this problem you will be given a secret code s1 …sn and a guess g1 …gn, and are to determine the hint. A hint consists of a pair of numbers determined as follows.
A match is a pair (i,j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj. Match (i,j) is called strongwhen i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.
Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (thelengthofthecode).Following these will be the secret code,representedas N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess. Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single ‘0’ (when a value for N would normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess,inorder,onehint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)

题解

猜数字游戏
数字对且位置也对的个数–直接对比答案和猜的数组即可
数字对但是位置不对的个数
这个时候需要遍历i(1~9),每次遍历,都寻找两个数组里等于i的元素个数,将得到的较小的那个元素个数加入结果中去,遍历完得到的结果便是只考虑数字而不考虑位置的个数,用它减去之前数字对且位置也对的个数,即为数字对但位置不对的个数

#include <cstdio>
#include <iostream>
using namespace std;
const int maxn = 1e3 + 5;

int n;
int a[maxn], b[maxn];

int main(){
    int kase = 0;
    while(scanf("%d", &n) == 1 && n) {
        for(int i = 0; i < n; ++i){
            scanf("%d", &a[i]);
        }
        printf("Game %d:\n", ++kase);

        for(;;){
            bool flag = 0;
            for(int i = 0; i < n; ++i){
                scanf("%d", &b[i]);
                if(b[i])flag = 1;
            }
            if(!flag)break;

            int ans1 = 0, ans2 = 0;
            for(int i = 0; i < n; ++i){
                if(a[i] == b[i]) ++ans1;
            }

            for(int i = 1; i <= 9; ++i){
                int k = 0, w = 0;
                for(int j = 0; j < n; ++j){
                    if(a[j] == i) ++k;
                    if(b[j] == i) ++w;
                }
                ans2 += min(k,w);
            }
            printf("    (%d,%d)\n", ans1, ans2 - ans1);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值