POJ2311 Cutting Game (博弈)

Cutting Game

Time Limit: 1000MS
Memory Limit: 65536K

Description

Urej loves to play various types of dull games. He usually asks other people to play with him. He says that playing those games can show his extraordinary wit. Recently Urej takes a great interest in a new game, and Erif Nezorf becomes the victim. To get away from suffering playing such a dull game, Erif Nezorf requests your help. The game uses a rectangular paper that consists of W*H grids. Two players cut the paper into two pieces of rectangular sections in turn. In each turn the player can cut either horizontally or vertically, keeping every grids unbroken. After N turns the paper will be broken into N+1 pieces, and in the later turn the players can choose any piece to cut. If one player cuts out a piece of paper with a single grid, he wins the game. If these two people are both quite clear, you should write a problem to tell whether the one who cut first can win or not.

Input

The input contains multiple test cases. Each test case contains only two integers W and H (2 <= W, H <= 200) in one line, which are the width and height of the original paper.

Output

For each test case, only one line should be printed. If the one who cut first can win the game, print “WIN”, otherwise, print “LOSE”.

Sample Input

2 2
3 2
4 2

Sample Output

LOSE
LOSE
WIN

Source

POJ2311

题意

一个n*m的网格,每次可以水平切割或垂直切割,第一个切出1*1大小的获胜,问先手胜负

题解

若当前状态无论怎么切割都会获得一个1*n(n>1)的网格,则为必败态,每次切割后会产生两个子游戏,利用sg函数求解,定义sg[1][1]=1(初始网格最小2*2,1*1的网格一定是上一个玩家剪下的)。AC代码如下

#include <cstdio>
#include <cstring>

using namespace std;

int W,H;
int sg[205][205];
int ans(int w,int h)
{
    if(sg[w][h]!=-1)
        return sg[w][h];
    bool vis[205];
    memset(vis,0,sizeof vis);
    for(int i=2;i<=h/2;i++)
        vis[ans(w,i)^ans(w,h-i)]=1;
    for(int i=2;i<=w/2;i++)
        vis[ans(i,h)^ans(w-i,h)]=1;
    for(int i=0;i<200;i++)
        if(vis[i]==0)
            return sg[w][h]=sg[h][w]=i;
}
int main()
{
    memset(sg,-1,sizeof sg);
    sg[1][1]=0;
    while(scanf("%d%d",&W,&H)!=EOF)
    {
        if(ans(W,H))
            printf("WIN\n");
        else
            printf("LOSE\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值