POJ2311——Cutting Game(sg函数)

Cutting Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3859 Accepted: 1438

Description

Urej loves to play various types of dull games. He usually asks other people to play with him. He says that playing those games can show his extraordinary wit. Recently Urej takes a great interest in a new game, and Erif Nezorf becomes the victim. To get away from suffering playing such a dull game, Erif Nezorf requests your help. The game uses a rectangular paper that consists of W*H grids. Two players cut the paper into two pieces of rectangular sections in turn. In each turn the player can cut either horizontally or vertically, keeping every grids unbroken. After N turns the paper will be broken into N+1 pieces, and in the later turn the players can choose any piece to cut. If one player cuts out a piece of paper with a single grid, he wins the game. If these two people are both quite clear, you should write a problem to tell whether the one who cut first can win or not.

Input

The input contains multiple test cases. Each test case contains only two integers W and H (2 <= W, H <= 200) in one line, which are the width and height of the original paper.

Output

For each test case, only one line should be printed. If the one who cut first can win the game, print "WIN", otherwise, print "LOSE".

Sample Input

2 2
3 2
4 2

Sample Output

LOSE
LOSE
WIN

也就是一个分解子游戏的过程


#include<iostream>
#include<cstdio>
#include<algorithm>
#include <queue>
#include<cstring>
#include <vector>
#include <set>
using namespace std;

const int MAXN = 200 + 10;

//记忆化搜索所用函数,初始化为-1
int mem[MAXN][MAXN];

//计算当前状态sg值
int sg(int w,int h){
    if(mem[w][h]!=-1)
        return mem[w][h];

    int vis[2000];
    memset(vis,0,sizeof(vis));
    //竖着切
    //把切下来的两张纸看作是两个游戏
    //则sg值可以看作是sg1^sg2
    //也就是说sg值的异或值等于多个游戏的复合状态
    for(int i=2;w-i>=2;i++)
        vis[sg(i,h)^sg(w-i,h)]=1;
    //横着切
    for(int i=2;h-i>=2;i++)
        vis[sg(w,i)^sg(w,h-i)]=1;
    int i=0;
    for(;;i++)
        if(vis[i]==0)
            return mem[w][h]=i;
}

int main(){
    int w,h;
    //一定要放在循环外面!要不然会T
    memset(mem,-1,sizeof(mem));
    while(scanf("%d%d",&w,&h)!=EOF){
        if(sg(w,h)!=0)
            puts("WIN");
        else
            puts("LOSE");
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值