158ugly numbers丑数

F - Ugly Numbers
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10
#include <iostream>
using namespace std;
const int maxn=6000;
int main()
{
    int dp[maxn],n,i;
    dp[1]=1;
    i=2;
    int two=1,three=1,five=1;
    while(i<=1501)//建立线性列表
    {
        dp[i]=min(min(2*dp[two],3*dp[three]),5*dp[five]);
        if(dp[i]==2*dp[two])two++;
        if(dp[i]==3*dp[three])three++;
        if(dp[i]==5*dp[five])five++;
        i++;
    }
    while(cin>>n,n)
        cout<<dp[n]<<endl;
    return 0;
}
学习心得:好不容易将烟草过程转化为计算机语言,好高兴,这也许就是暑假辛辛苦苦赖在实验室刷题的原因
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值