STL-F&V Ugly Numbers

F:

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 1, 2, 3, 4, 5, 6, 8, 9, 10, 12, 15, … shows the first 11 ugly numbers. By convention, 1 is included. Write a program to find and print the 1500’th ugly number.

Input

There is no input to this program.

Output

Output should consist of a single line as shown below, with ‘’ replaced by the number computed.

Sample Output

The 1500’th ugly number is .

   #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<queue>
    #include<set>
    #include<vector>
    using namespace std;
    typedef long long ll;//定义long long为ll
    const int base[]={2,3,5};
    int main()
    {
        priority_queue<ll,vector<ll>,greater<ll> >pq;//优先队列:<类型,<存储方式>,<比较函数> >;
        set<ll>s;//集合标记某个数字是否出现过
        s.insert(1);
        pq.push(1);
        int cnt=0;
        while(1)
        {
            ll x=pq.top();
            pq.pop();//取出对首的数
            cnt++;
            if(cnt==1500)
            {
                cout<<"The 1500'th ugly number is "<<x<<"."<<endl;
                break; 
            }
            ll tmp;
            for(int i=0;i<3;i++)
            {
                tmp=x*base[i];//产生2x,3x,5x
                if(s.count(tmp)==0)//没有出现过
                {
                    s.insert(tmp);//标记tmp出现过
                    pq.push(tmp);//tmp插入队列
                }
            }
        }
        return 0;
    }

V:

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 1, 2, 3, 4, 5, 6, 8, 9, 10, 12, … shows the first 10 ugly numbers. By convention, 1 is included. Given the integer n,write a program to find and print the n’th ugly number.

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

#include<cstdio>
#include<algorithm>
#include<queue>
#include<map>
#include<iterator>
using namespace std;
typedef long long ll;
const int maxn=1505;
int base[]={2,3,5};
ll dp[maxn];
priority_queue<ll,vector<ll>, greater<ll> >pq;
map<ll,int>m;
int n;
void uglynumbers()
{
   pq.push(1);
   m[1]=1;
   int cnt=0;
   while(true)
   {
      ll a=pq.top();
      pq.pop();
      cnt++;
      if(cnt>1500+4)
      break;
      for(int i=0;i<3;i++)
      {
          ll b=a*base[i];
          if(!m[b])
          {
              m[b]=1;
              pq.push(b);
          }
      }
   }
   map<ll,int>::iterator it;
   cnt=1;
   for(it=m.begin();it!=m.end();it++)
   {
       dp[cnt++]=it->first;
       if(cnt>1500)
       return;
   }
}
int main()
{
    uglynumbers();
    while(~scanf("%d",&n),n)
    {
        printf("%I64d\n",dp[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值