HDU 1031.Design T-Shirt【结构体二次排序】【8月21】

Design T-Shirt

Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
 

Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
 

Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
 

Sample Input
  
  
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
 

Sample Output
  
  
6 5 3 1 2 1
n个人,m件衣服,输出评价最高的前k件,输出时,评价相同的标号大的先输出。 一定要二次排,因为可能全部的评价一样高,只排一次输出就会有错误。

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
struct ss{
    double v;
    int x;
};
bool cmp1(ss x,ss y){
    if(x.v>y.v) return true;
    else return false;
}
bool cmp2(ss x,ss y){
    if(x.x>y.x) return true;
    else return false;
}
int main(){
    int n,m,k;
    double t;
    ss f[1010];
    while(scanf("%d%d%d",&n,&m,&k)==3){
        for(int i=0;i<m;i++)
            f[i].v=0;
        while(n--)
        for(int i=0;i<m;i++){
            scanf("%lf",&t);
            f[i].v+=t;
            f[i].x=i+1;
        }
        sort(f,f+m,cmp1);
        sort(f,f+k,cmp2);//二次排,只排前k项
        for(int i=0;i<k;i++){
            if(i!=0) printf(" ");
            printf("%d",f[i].x);
        }
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值