Design T-Shirt
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3018 Accepted Submission(s): 1500
Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
Sample Input
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
Sample Output
6 5 3 1 2 1
Author
CHEN, Yue
Source
Recommend
Ignatius.L
#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
#include <vector>
#include <queue>
#include <stack>
#define LL long long
#define MAXI 2147483647
#define MAXL 9223372036854775807
#define eps (1e-8)
#define dg(i) cout << "*" << i << endl;
//2511.1731.2334
using namespace std;
struct ELE
{
double satisfaction;
int id;
}ele[500];
bool operator < (const ELE& a, const ELE& b)
{
if (fabs(a.satisfaction - b.satisfaction) > eps) return a.satisfaction - b.satisfaction > eps;
return a.id < b.id;
}
bool cmp(const int& a, const int& b)
{
return a > b;
}
/*不能使用运算符重载以使得整数从大到小排列,需要自定义比较函数cmp
bool operator < (const int& a, const int& b)
{
return a > b;
}*/
int main()
{
int N, M, K, i;
double s;
while(scanf("%d %d %d", &N, &M, &K) != EOF)
{
for(i = 1; i <= M; i++)
{
ele[i].satisfaction = 0.0;
ele[i].id = i;
}
while(N--)
{
for(i = 1; i <= M; ++i)
{
scanf("%lf", &s);
ele[i].satisfaction += s;
}
}
sort(ele + 1, ele + M + 1); //注意排序是由ele[1]开始
vector<int> v;
for(i = 1; i <= K; ++i)
v.push_back(ele[i].id);
sort(v.begin(), v.end(), cmp); //这里使用自定义比较函数cmp使得排序结果是降序,否则默认升序。
vector<int>::iterator it = v.begin();
printf("%d", *it);
for(it++; it != v.end(); ++it)
printf(" %d", *it);
puts("");
/*使用这个方法排序出现segmentation fault
vector<int>::iterator it = v.end() - 1;
printf("%d", *it);
for(--it; it != v.begin(); --it)
printf(" %d", *it);
printf(" %d\n", *it);*/
}
return 0;
}