Ones

这题通过团友以及百度的翻译,同时还参照了 http://blog.csdn.net/yming0221/article/details/6370117  意思基本上清楚了:输入一个不能被2或者5的数,输出这个数的倍数的最小位数,这个倍数全部由1组成

描述

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

输入

Each line contains a number n.

输出

Output the number of digits.

样例输入

3
7
9901

样例输出

3
6
12
#include<iostream>
using namespace std;
int fun(int n)//按常规的方法肯定会超时,在这里我们可以用mod的方法进行计算
{
    int c=0,m=n;
    while(n)
    {
        n=n*10+1;
        c++;
        n%=m;
    }
    return c;
}
int main()
{
    int n;
    while(cin>>n)
    {
        cout<<fun(n)<<endl;
    }
    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值